首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
V2EX  ›  Linux

debian stretch 推荐个能用的 usb 无线网卡吧

  •  
  •   1800x · 40 天前 · 1133 次点击
    这是一个创建于 40 天前的主题,其中的信息可能已经有所发展或是发生改变。
    Debian GNU/Linux 9 (stretch)
    linux 4.9

    已经尝试了三款 usb 无线网卡了,其中两款还是特意新买的
    一款芯片并非网上说的那样
    另两款芯片在 debian 支持清单里,但实际上只能搜到 wifi,连不上
    笔记本自带无线网卡坏了。现在的解决方案是路由器无线转有线

    求推荐
    坚决不要 RTL 芯片的
    17 回复  |  直到 2019-04-17 10:37:27 +08:00
        1
    msg7086   40 天前
    新硬件的话先试着把内核升到 buster 的 4.19 看看?
        2
    yanaraika   40 天前 via Android
    装 firmware-linux 了吗
        3
    1521815837   40 天前 via Android
    树莓派吗?
        4
    fox0001   40 天前 via Android
    @1521815837 #3 树莓派 3/3B 已自带无线网卡
        5
    shuianfendi6   40 天前
    rtl 方案需要自编译驱动,贼麻烦
    ar 的考虑下?
        6
    chen006   40 天前 via Android
    腾达 u12,官网提供 linux 驱动,rtl8812au
        7
    BOYPT   40 天前
    内核太旧了,而且这些都要 firmware 支持,debiam 都不带非自由 firmware 包的,要自己折腾进去
        8
    iwtbauh   40 天前 via Android
    真要推荐的话,参考 fsf 的 h-node.org ,选其中高通 ar/qca 芯片、马威尔芯片或者牙膏厂(开源友好,但性能糟糕)

    大致原则是尽量避免博通(没用过,但是对开源及其差)和联发科(用过多个芯片组,包括 rt2860、mt7603e 等等,驱动乱七八糟臃肿不堪,不符合 Linux 标准,自造轮子难以整合)
        9
    iwtbauh   40 天前 via Android
    @BOYPT #7

    并不自己折腾啊,启用非自由源就可以 apt 了,而且 x86 (包括 amd64 )版本的 debian 安装镜像检测到这些硬件还会提醒你是否启用。
        10
    51Tao   40 天前
    tp-link 的不就可以吗, https://www.debian.cn/
        11
    BOYPT   40 天前
    @iwtbauh #9 我这有个 AP6212 的,apt 里面的包提供的 firmware 完全不能用,要自己下厂商版本的覆盖过去。还得锁包,不然升级时候覆盖掉就没网了。
        12
    iwtbauh   40 天前 via Android
    @BOYPT #11

    博通的无线芯片组吗,那倒是有可能。选博通和联发科就意味着要折腾。

    你安装的是 backports 版本的 firmware-brcm80211 吗
        13
    atzlinux   40 天前
    lsusb ,dmesg 看下无线网卡拔插后的信息,如果有提示识别,那在内核驱动层面,就应该支持了。

    如果没有,就需要先增加内核驱动,这个安装会麻烦一些。firmware,module 都有可能需要折腾。

    lspci 命令,也是可以看下。

    驱动安装 OK 后,接下来 iwifconfig,用 linux 下命令无线网卡配置工具测试下手工配置网络参数。
        14
    feng32   40 天前 via Android
    这个我之前做过调研,Tenda U12 确实是目前市面上最便宜的、支持 Linux 的 802.11ac 双频 2x2 MIMO(1300Mbps) USB 无线网卡

    欢迎挑战
        15
    reus   40 天前
    内核版本太旧了,所以驱动不完善吧
        16
    F32   40 天前
    如果楼主要自己挑选,目前最权威的数据在这里 https://wikidevi.com
        17
    1800x   39 天前
    @feng32 @chen006 tenda u12
    rtl 芯片 怕了 不敢用
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2264 人在线   最高记录 5043   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 18ms · UTC 10:01 · PVG 18:01 · LAX 03:01 · JFK 06:01
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1