首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
拉勾
V2EX  ›  程序员

请教一个 zabbix 的问题,小弟安装了 pgsql 版本的 zabbix,但是在 HTTP://IP/ZABBIX 配置的时候数据库配置选项仍然只有 MYSQL 求助?

  •  
  •   praynise · 2017-11-19 21:21:17 +08:00 · 1832 次点击
    这是一个创建于 491 天前的主题,其中的信息可能已经有所发展或是发生改变。
    求助,小弟在官方 yum 源安装了 zabbix3.4 版本的 server 和 web,但是在使用 http://localhost/zabbix,Configure DB connection 中的 Database type 仍然只有 MYSQL 一个选项,请问如何能够让 zabbix 连接 pgsql 数据库呢,非常感谢~

    小弟 rpm -qa | grep zabbix 命令结果:
    [root@red-hat-enterprise-linux ~]# rpm -qa | grep zabbix
    zabbix-web-pgsql-3.4.4-2.el6.noarch
    zabbix-server-pgsql-3.4.4-2.el6.x86_64
    zabbix-release-3.4-1.el6.noarch
    zabbix-web-3.4.4-2.el6.noarch
    5 回复  |  直到 2017-11-20 10:47:16 +08:00
        1
    khy   2017-11-19 21:23:49 +08:00
    噢,这个版本的没用过,默认 mysql 了?修改一下配置文件就好了。
        2
    praynise   2017-11-19 21:38:10 +08:00
    @khy 请问具体是哪个配置文件呢?
        3
    gstqc   2017-11-19 23:21:13 +08:00 via iPhone
    删掉 zabbix-web-3.4.4-2.el6.noarch
        4
    praynise   2017-11-20 07:29:26 +08:00
    @gstqc 没法删掉的,zabbix-web-pgsql-3.4.4-2.el6.noarch 依赖 zabbix-web-3.4.4-2.el6.noarch …
        5
    litter123   2017-11-20 10:47:16 +08:00
    emmm......pqsql 和 mysql 应该是类似的吧?或者看看安装文件源码有没有这个选项?
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4097 人在线   最高记录 4385   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 16ms · UTC 01:58 · PVG 09:58 · LAX 18:58 · JFK 21:58
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1